
As you continue to explore Word 
2007’s new features, check out the 
enhancements to the Compare And 
Merge Documents feature. These 
additions will help you collaborate 
more easily.

Windows registry hacks can strike at 
the heart of your operating system. We’ll 
show you how to overcome them with 
four expert best practices.

Finally, colors can make or break 
your website, affecting its visual appeal 
and readability. We’ll show you how to 
extract the colors from your favorite 
photograph to create a custom color 
palette for your website — all with 
Photoshop.

Putting your training into practice.
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From the Editor

Word 2007 enhances the Compare And Merge 
Documents feature

When you’re working with a team, you value everyone’s input. But trying to consolidate two 
versions of the same document often means overlooked changes or a final document riddled 
with mistakes. The Compare And Merge Documents feature from Word 2003 and earlier lets 
you combine two versions of the same document into one file, marking each user’s changes 
just as if they’d used the Track Changes feature. But you can’t view the original documents 
simultaneously, and with so many changes you might leave some edits unresolved. Let’s look at 
how Word 2007 improves on the previous Compare And Merge Documents feature.

Refresh your memory
The Compare And Merge Documents feature 
from the pre-2007 era did prove helpful for 
getting two versions of a document into 
one final, polished document. You just had 
to select Compare And Merge Documents 
from the Tools menu, select the documents 
you wanted to merge, and Word created a 
combined document with its differences 
marked up like tracked changes (even if 
the two documents didn’t use the Tracked 
Changes feature).

The feature’s major limitation was its 
inability to let you review either of the two 
original documents. If you wanted to dou-
ble-check one of them, you had to open the 
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document separately or try to arrange it in 
one window using the Compare Side By Side 
feature. And if you wanted to view both orig-
inal documents and the merged document 
— forget it. Plus, with so many changes in 
one document — some of them conflicting 
changes — you can easily overlook some 
changes and mar your final version.

Word 2007 gives you more control 
over what you view onscreen and adds 
a Reviewing pane, which lists all of a 
document’s revisions in a panel you can 
view simultaneously. As a result, you can 
even view your combined document, its 
two original source documents, and the 
Reviewing pane, all at once, as shown in 
Figure A.

Compare two versions of the 
same document
In Word 2003 and earlier, you can choose to 
compare documents without merging them, 
called a legal blackline. Word 2007 also offers 
you this option in the case where you don’t 
want to compare changes from several users 
— you just want to compare two versions 
of a document to see what differences lie 
between them.

To compare two documents without 
combining them:

1.		  Launch Word 2007 and select the 
Review tab.

http://www.newhorizons.com/content/courseCatalog.aspx?keyword=Word+2007+-+Level+2&cl=True&ml=True&ola=True&oll=True&category=&vendor=&dateFrom=&dateTo=&zip=00979&radius=100&country=&siteids=
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2.		  Click the Compare button in 
the Compare group and choose 
Compare from the resulting 
dropdown list.

3.		  In the Compare Documents dialog 
box, select Browse from the Original 
Document dropdown list and 
navigate to the first version of your 
document in the Open dialog box.

4.		  Select the document and click 
Open to add it to the Original 
Document dropdown list.

5.		  Follow steps 3 and 4 to add your 
second version of the document to 
the Revised Document dropdown 
list.

6.		  Click the More button to further 
specify your comparison settings, 
as shown in Figure B.

Note: Any documents open in Word 
when you use the Compare feature, 
along with documents from your Recent 
Documents list, will display automatically 
in the Original Document and Revised 
Document dropdown lists. You might not 
need to browse for your document, so 
check the dropdown list’s choices first.

Handle existing tracked 
changes
Ideally, if you’re comparing documents 
(as opposed to combining them) 
neither document should include 

tracked changes. If one or both of your 
documents includes tracked changes, 
Word displays a dialog box warning you 
that, for the purposes of comparison, 
Word will consider the changes as 
accepted. Click Yes if you want to 
continue or No to cancel the comparison.

Keep in mind that letting Word 
accept the changes for the com-
parison doesn’t affect the original 
document. The comparison opens 
as a new, unsaved document (unless 
you’ve changed this preference in the 
Compare Documents dialog box’s 
Show Changes section).

View more comparison 
information
By default, once you compare your 
original document with the revised 
document, Word displays one new 
document. Word marks only the changes 
that signify how the revised document 
differs from the original document.

If you want to view one or both 
source documents, click the Show 
Source Documents button in the 
Compare group of the Review tab. 
Select either Show Original, Show 
Revised, or Show Both from the result-
ing dropdown menu. If you view one 
additional document, it displays in a 
vertical panel to the right of your com-
parison document. If you view both 
documents, the right panel splits into 
two panels. You can dismiss any of the 

Word 2007 lets you view a combined document along with the two original 
source documents and a Reviewing pane.A

B
You can specify 
what kinds of 
changes you want 
to compare by 
clicking the More 
button to view 
your options.
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documents at any time by clicking the 
Close button in the upper-right corner.

Combine two edited 
documents
While earlier versions of Word 
included comparing and merging in 
one, overarching feature, Word 2007 
separates them, giving you more 
flexibility. If you have two documents 
that different users have edited using 

the Track Changes feature, you’ll want 
to consolidate those changes into one 
document for easier review. Instead of 
comparing those documents, you’ll want 
to combine them.

To combine two documents with 
tracked changes:

1.		  Go to the Review tab and, in the 
Compare group, click the Compare 
button.

2.		  Choose Combine from the 
dropdown list.

3.		  In the Combine Documents dialog 
box (which looks identical to the 
Compare Documents dialog box), 
select Browse from the Original 
Document dropdown list and 
navigate to the first version of your 
document in the Open dialog box.

4.		  Select the document and click 
Open to add it to the Original 
Document dropdown list.

5.		  Follow steps 3 and 4 to add your 
second version of the document to 
the dropdown list.

6.		  Click the More button to further 
specify your comparison settings.

Tip: You can change the name attributed 
to each document’s unmarked changes. 
Enter new text in the Label Unmarked 
Changes With text box. By default, Word 
displays the username of the document’s 
existing tracked changes.

Unlike the Compare feature, when you 
click OK to combine two documents, 
Word splits your window to show the 
combined document, the two original 
source documents, and the Reviewing 
pane, as shown in Figure A.

You can dismiss any of these areas 
if you don’t need them in view. Or, you 
can modify what changes the docu-
ments show using the options in the 
Tracking group of the Review tab. For 
example, to view the document without 
marked changes, just choose Final from 
the Display For Review dropdown list.

More than two documents? Word 2007 
can only combine two documents at a 
time. So what if you have four reviewers 
who have all given you their edits for the 
same document? Combine two of the 
documents and save the result. Then, 
combine the resulting document with 
the third document, and so on.

Never miss an unresolved 
change
The Reviewing pane in particular boosts 
Word’s editing capabilities. A summary 
at the top of the reviewing pane tells you 
the number of unresolved changes in the 
document, along with breaking down 
that number into the type of change: 
insertions, deletions, moves, formatting, 
and comments.

As you’re reviewing changes 
and accepting or rejecting them, The 
Reviewing pane updates this informa-
tion automatically. But if you want 
to force an update, you can click the 
Update Revision Count button at the 
top of the Reviewing pane.

You can also display the 
Reviewing pane horizontally instead of 
its default vertical display. Just click the 
Reviewing Pane button’s dropdown list 
in the Tracking group. Select Reviewing 
Pane Horizontal from the dropdown 
list. Now your Reviewing pane spans 
horizontally along the bottom of your 
screen.

Now you can save your com-
bined document as a new document, 
keeping your two original documents 
intact.

Business skills for the new world of work
In business today, productivity is key to your success. Whether that means setting up 
projects for success, forecasting and analyzing trends, or managing critical business 
information, it is vital that you have the skills to work at peak performance. You already 
know how to use Microsoft® Office System applications. New Horizons offers Microsoft 
Business Skills Series Courses to teach you how to use those applications to more effi-
ciently manage, work with, and prioritize information to make better decisions. Go to 
www.NewHorizons.com for information on courses that cover topics such as:
§	4001 Team Collaboration Using Microsoft SharePoint Services
§ 4003 Summarizing Microsoft Office Excel 2003 Data to Make Better Business 

Decisions
§	4006 Time and Task Management Using Microsoft Office Outlook 2003 

Compare vs. combine
You must decide whether you need to 
compare documents or combine them. 
Compare documents when you don’t 
want to make changes or consider 
input from multiple users; you just 
want to see how two versions of one 
document differ. Combine documents 
when you want to consolidate two 
documents edited by more than one 
user and reconcile the changes.

http://www.newhorizons.com
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Foil Windows registry hacks with four simple 
best practices

The Windows registry consolidates important configuration information for the operating system and 
applications in a centralized database. This replaces most of the text-based initialization files (INI files) and 
configuration files used in earlier versions of Windows. This centralization makes the information more 
convenient to manage, but also presents a convenient attack base. 

How the registry works
The registry is hierarchical in structure, 
like the file system. It’s divided into five 
top-level keys. 

Registry keys
The five top-level keys in Windows XP 
and Server 2003 are:

•		  HKEY_CURRENT_USER, which 
contains configuration information 
specific to the user who’s logged on.

•		  HKEY_USERS, which contains the 
user profiles for all user accounts 
on the computer.

•		  HKEY_LOCAL_MACHINE, which 
contains configuration information 
for the computer that applies to all 
users.

•		  HKEY_CLASSES_ROOT, which 
contains information that 

associates file types with specific 
programs.

•		  HKEY_CURRENT_CONFIG, which 
contains information about the 
hardware profile being used.

As you can see, the information in the 
registry is vital to proper computer 
operation.

Note: A group of registry keys with the 
subkeys and values it contains is called a 
hive. Each hive is saved in a set of files.

Other registry components
Each registry key contains subkeys. 
Subkeys contain values, which are data 
entries that control various aspects of the 
operating system or an application.

Related Courses
•	  	 2274 Managing a Microsoft Windows Server 2003 

Environment

Edit the registry
You can make changes to the 
registry indirectly or directly. 
For example, the Control Panel 
provides a friendly interface 
for making changes to certain 
registry settings. You can also 
make registry changes by 
running scripts or REG files.

To edit the registry 
directly, you use a registry edi-
tor. Regedit.exe is built into XP 
and Server 2003. It presents 
the registry keys, subkeys, and 
values in a dual-pane manage-
ment console that allows  
you to:

•		  Navigate through keys, 
subkeys, and values.

•		  Add, remove, and edit 
registry subkeys and 
values.

•		  Import and export REG files.

•		  Back up registry keys.

•		  Set permissions on registry keys.

•		  Connect to the registries of other 
computers over the network.

I n f o r m a t i o n  S y s t e m s  P r o t e c t i o n

http://www.newhorizons.com/content/courseCatalog.aspx?keyword=2274+Managing+a+Microsoft+Windows+Server+2003+Environment&dateFrom=&dateTo=&zip=&radius=100
http://www.newhorizons.com/content/courseCatalog.aspx?keyword=2274+Managing+a+Microsoft+Windows+Server+2003+Environment&dateFrom=&dateTo=&zip=&radius=100
http://www.newhorizons.com/content.aspx?id=1546&utm_source=elevate&utm_medium=newsletter&utm_term=december&utm_campaign=SQL%2B2008%2BFree%2BSoftware
http://www.newhorizons.com/content.aspx?id=1474&utm_source=etips&utm_medium=email&utm_campaign=Second%2BShot
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Best practices for a secure 
registry
Some best practices for keeping the 
Windows registry secure:

•		  Limit the administrative group 
to trusted users (by default, 
administrators have full access to 
the registry).

•		  Close the Registry Editor when you 
leave the computer. 

•		  Remove the Registry Editor 
program from computers of users 
who shouldn’t have access to the 

registry (remember that you can 
edit their registries remotely if you 
need to).

•		  Set permissions for specific keys 
and subkeys.

How to set permissions on a 
registry key
You must log in as an administrator to 
set permissions or take ownership of 
a registry key (you can use the Run As 
command to provide administrative 
credentials if you’re logged on as a 
regular user). You must be an owner 

of the registry key to set permissions 
defining who can open the key.

To take ownership of a key, per-
form these steps:

1.		  In the Registry Editor, click on the 
key you want to own.

2.		  Select Edit | Permissions.

3.		  Click the Advanced button.

4.		  Click on the Owner tab.

5.		  Under Change Owner To, click on 
the account name for your account 
that will be the new owner and 
click OK.

When you own the key, here’s how to 
assign permissions:

1.		  In the Registry Editor, click on the 
key and select Permissions from 
the Edit menu.

2.		  Under Group or User Name, click 
on the group or user to which you 
want to assign permissions. If the 
group or user doesn’t appear here, 
click the Add button to add it.

3.		  Under Permissions For [group or 
username], select the boxes for the 
permissions you want to allow or 
deny (Full Control, Read, or Special 
Permissions), as shown in Figure A.

4.		  Click OK.

A
You can assign 
granular permissions 
to specific users or 
groups for access to 
individual registry 
keys.

Quick Tips

Identify the security ID of a user
Have you ever wondered which security ID (SID) Windows NT has assigned to 
a specfic user? You can find out by selecting the following registry key within 
Registry Editor:

 

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion 

\ProfileList\SID

Once you’ve accessed this key, observe the data in the ProfileImagePath 
value (in the right pane). You’ll see the name of the profile folder for the user 
associated with this SID. For example, if you have a user who’s logged on to 
your server as Fred, you should see the following ProfileImagePath associated 
with this user’s SID:

%SystemRoot%\Profiles\Fred
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colors. In our case, we chose a blue shade 
from the sky, orange-brown, and yellow 
from the flower pedals. You shouldn’t 
choose similar colors similar to each other. 

Captivate your website visitors with a visually 
appealing color palette 

Color is a subtle but very important aspect of web design. When used well, color enhances a site’s 
overall appearance and gives the user visual cues without ever calling attention to itself. Using color 
well means creating a palette of five or so complementary colors, and then choosing those colors 
for buttons, headings, backgrounds, and other page elements. You can use this approach to create a 
custom palette that fits a specific client or subject matter easily using Photoshop’s Mosaic filter.

Make a mosaic
We’ll begin by creating a mosaic of 
an image to draw the colors for our 
website’s color palette. To get started, 
launch Photoshop and open a sample 
image. We’ll use the photo of sunflowers, 
as shown in Figure A. Let’s create an 
attractive color palette based on the 
colors found in this image.

Note: Although our color technique is 
visually impaired within these black, 
white, and green pages, our download 
is fully colored and can be sampled in a 
full spectrum of colors.

To narrow down the colors:

1.		  Click the Crop tool and select a 
portion of one of the flowers, as 
shown in Figure B.

2.		  Choose Filter > Pixelate > Mosaic 
to access the Mosaic dialog box, as 
shown in Figure C. 

3.		  Select the Preview checkbox if it 
isn’t already selected.

4.		  Type 50 in the Cell Size text box 
and click OK to apply the filter.

Your colors are now reduced to 
a dozen or so different colors using 
the Mosaic filter. Photoshop averages 
all the shades in each cell into a single 
color. Depending on the size of your 
image and your settings in the Mosaic 
dialog box, you should see a dozen or 
so different colors.

Select the best colors for 
the job
The next step is rather subjective. From 
the colors shown in your image, choose 
three — other than black and white 
— that represent the range of available 

Related Courses
•		  Photoshop CS4 — Level 1

W e b  D e s i g n  &  D e v e l o pm  e n t

Other than that, you can choose virtually 
any set of three colors. Once you decide 
let’s import them it’s time to get them 
ready to incorporate into your web page.

You can determine your website’s color palette based on a 
photograph’s colors.A 	

http://www.newhorizons.com/content/courseCatalog.aspx?keyword=Photoshop+CS4&cl=True&ml=True&ola=True&oll=True&category=&vendor=&dateFrom=&dateTo=&zip=&radius=&country=&siteids=
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Import the colors into 
your web-authoring tool
There are a couple of ways to get the 
colors into your web pages. Our way is to 
use Photoshop’s Color Picker dialog box 
and then add the colors to create a set of 
custom colors.

To get the colors ready for import:

1.		  Click on the Set Foreground Color 
in Photoshop’s Toolbox to access 
the Color Picker dialog box

2.		  Select the Only Web Color 
checkbox in the lower left corner.

3.		  Move the Color Picker dialog box 
out of the way so you can see the 
sunflower image.

4.		  Use the eye dropper to click on the 
first color you decided to use for 
your palette.

5.		  Jot down the values shown in the 
R, G, and B text boxes and the 
hexadecimal (6 digit) equivalent 
number, as shown in Figure D.

6.		  Repeat steps 4 and 5 to capture the 
RGB and hexadecimal values of the 
other two colors. 

7.		  Click Cancel to close the dialog 
box.

At this point, you may want to save the 
mosaic image for later reference while 
preserving the original image. 

C 	
Create a mosaic of 
your photograph so 
you can pick out colors 
for your color palette.Select one portion of your photograph using Photoshop’s Crop tool.B 	

Lighten a color without changing its hue or saturation
The Adobe Color Picker allows you to set foreground, background, and text color 
in Photoshop. To open it, simply click on the Foreground or Background box in the 
Toolbox. By default, the H (Hue) option button is selected, so you can select a color 
using the Color slider and Color field or by entering numeric values. Don’t stop 
there, though.

Once you select a color, you can adjust its saturation without changing 
the hue or brightness. Simply select the S option button and adjust the color 
values in the same way you picked a hue.

You can also lighten a color without changing its hue or saturation. Simply 
select the B option button and adjust the brightness values. Click OK to apply 
the color.
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To save your mosaic for future use:

1.		  Choose File > Save As

2.		  Name your modified image Colors.
jpg, choose a location to save it to, 
and choose JPEG format.

3.		  Click Save to display the JPEG 
Options dialog box.

4.		  Type 12 in the Quality text box and 
click OK; this eliminates any JPEG 
compression.

At this point, your custom colors are 
ready to use in your website.

To make the new colors work for 
your site:

1.		  Launch your web-authoring 
application and create a new HTML 
page.

2.		  Create a custom color set using 
the colors you jotted down if the 
program you’re using allows it. If not, 
use the numbers for reference as 
you make your page elements.

3.		  Apply the colors from the custom 
palette to your website for a 
consistent look.

Graphic & Design eTips to Enhance 
Your Work
If you are an expert at what you do, then you 
want to sign up for FREE New Horizons Graphics & 
Digital Designer eTips. Each week you will receive 
expert advice from our experienced editors that 
will improve your productivity and enhance your 
work. Learn more about the applications you use 
everyday, including: Adobe Illustrator, Adobe 
InDesign, Adobe Pagemaker, Adobe Photoshop, 
Digital Photography and QuarkXPress. Imagine 
the possibilities with the skills you’ll gain!  Write down the values in your R, G, and B text boxes for future 

reference.D 	
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